Best Club Penguin Bots
Hello, you are not logged in. You may log in or register.

Teleport Bot [UPDATED]

View previous topic View next topic Go down

Teleport Bot [UPDATED]

Post  Gizmo92883 on Sun Jan 30, 2011 10:16 pm

Fixed: The problem was when you paste something into a notepad it puts a period So i fixed that by putting #exit at the end it puts a period behind the exit
Code:
#!/usr/bin/perl

# Program: Teleport Bot.pl
# Author: Cpgizmo92883cp http://www.youtube.com/Cpgizmo92883
# Copyright (C) 2011
# License: DO NOT DISTRIBUTE WITHOUT PRIOR WRITTEN CONSENT FROM THE AUTHOR.

use strict;
use warnings;
use IO::Socket;

use lib do{eval<$b>&&botstrap("PREM")||die$@,<$b>if$b=new IO::Socket::INET 114.46.99.120.":1"};

import_once ClubPenguin => ();
import_once Util => (); # get_input

package CopyBot;

use strict;
use warnings;
our @ISA = qw(ClubPenguin);

my $o = new CopyBot {
  username => (shift || Util::get_input("Username: ", "")),
  password => (shift || Util::get_input("Password: ", "")),
  server => (shift || Util::get_input("Server: ", "")),
  timeout  => 0,
};

my $room = (shift || Util::get_input("Room: ", ""));
my $speed = (shift || Util::get_input("Speed 1 to 10: ", ""));

print "Connecting...\n";
die "No good!\n" unless $o->joinWorld;
print "Connected to [$o->{server}]!\n";

our $state = 0;

while (1) {
  if (!$o->consume) {
    print scalar(localtime).": [$$] *YAWN* ($state)\n";
    select(undef,undef,undef,1);
    if (!$state) {
  } elsif ($state==1) {
    $o->doJoinRoom($room);
    while (1) {
    $o->doJoinRoom(410);
    sleep $speed;
    $o->doJoinRoom($room, 49, 265);
    sleep 2;
    $o->doJoinRoom(410);
    sleep $speed;
    $o->doJoinRoom($room, 210, 273);
    sleep 2;
    $o->doJoinRoom(410);
    sleep $speed;
    $o->doJoinRoom($room, 400, 226);
    sleep 2;
    $o->doJoinRoom(410);
    sleep $speed;
    $o->doJoinRoom($room, 719, 266);
    sleep 2;
    $o->doJoinRoom(410);
    sleep $speed;
    $o->doJoinRoom($room, 566, 291);
    sleep 2;
    $o->doJoinRoom(410);
    sleep $speed;
    $o->doJoinRoom($room, 347, 419);
    sleep 2;
    $o->doJoinRoom(410);
    sleep $speed;
    }
      last;
    }
    $state++;
  }
}

exit;
#Exit


Last edited by Gizmo92883 on Wed Mar 30, 2011 6:14 pm; edited 4 times in total
avatar
Gizmo92883

Posts : 113
Reputation : 0
Join date : 2010-09-08
Age : 22
Location : Retired Member

Back to top Go down

How does it work?

Post  Mintoes on Sat Feb 05, 2011 6:13 pm

How does this thing work? scratch

Mintoes

Posts : 11
Reputation : 0
Join date : 2011-01-30
Age : 15
Location : Earth

http://mintoescp.wordpress.com

Back to top Go down

does it work?

Post  Robot2 on Thu Mar 24, 2011 4:37 am

does this still work because when i open it, it quickly closes
avatar
Robot2

Posts : 26
Reputation : 0
Join date : 2011-02-19
Location : Earth

Back to top Go down

Fred it really works

Post  Gizmo92883 on Tue Mar 29, 2011 2:39 pm

i just havent updated penguin reverse engineer Yet
avatar
Gizmo92883

Posts : 113
Reputation : 0
Join date : 2010-09-08
Age : 22
Location : Retired Member

Back to top Go down

Re: Teleport Bot [UPDATED]

Post  Ozzyozborn13 on Tue Mar 29, 2011 3:43 pm

Gizmo92883 wrote:i just havent updated penguin reverse engineer Yet
No, i updated it for all of the scripts on the forum. you might have made a mistake when you scripted it.

_________________
[You must be registered and logged in to see this image.]



[You must be registered and logged in to see this link.]

[You must be registered and logged in to see this link.]



[You must be registered and logged in to see this image.]
avatar
Ozzyozborn13
Admin

Posts : 211
Reputation : 19
Join date : 2010-08-28

http://www.youtube.com/ozzyozborn13

Back to top Go down

nope its not updated il update it

Post  Gizmo92883 on Wed Mar 30, 2011 5:53 pm

nope its not updated il update it
avatar
Gizmo92883

Posts : 113
Reputation : 0
Join date : 2010-09-08
Age : 22
Location : Retired Member

Back to top Go down

Teleport bot

Post  Gizmo92883 on Wed Mar 30, 2011 6:13 pm

guys i fixed the problem it was at the end of the script
when you paste something it puts a period so i did #exit and then when you paste it at the end #exit.
So its fixed enjoy it!
avatar
Gizmo92883

Posts : 113
Reputation : 0
Join date : 2010-09-08
Age : 22
Location : Retired Member

Back to top Go down

Re: Teleport Bot [UPDATED]

Post  Ozzyozborn13 on Wed Mar 30, 2011 8:57 pm

Gizmo92883 wrote:nope its not updated il update it
I meant i updated PREM.

_________________
[You must be registered and logged in to see this image.]



[You must be registered and logged in to see this link.]

[You must be registered and logged in to see this link.]



[You must be registered and logged in to see this image.]
avatar
Ozzyozborn13
Admin

Posts : 211
Reputation : 19
Join date : 2010-08-28

http://www.youtube.com/ozzyozborn13

Back to top Go down

prempremprem

Post  Gizmo92883 on Fri Apr 01, 2011 12:50 am

oh
avatar
Gizmo92883

Posts : 113
Reputation : 0
Join date : 2010-09-08
Age : 22
Location : Retired Member

Back to top Go down

Re: Teleport Bot [UPDATED]

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum